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1. Insert dataset into excel

Figure 1: Import Dataset1

Under the Data tab, in the Get & Transform Data group, click From Text/CSV. Then, click
import in the dialog box to import the text file Dataset1 into the excel worksheet.

Figure 2: Load Dataset1

In the preview dialog box, select Load to load the data directly to a new worksheet.



Figure 3: Output of importing Dataset1

Once the data is successfully loaded, it will be displayed in the worksheet as shown in figure 3.



2. Convert data values to two decimal places

Figure 4: Convert data values to two decimal places

Highlight the columns from Academic to Test_2, under the Home tab, in the Number group,
select the dropdown list and click Number to convert the data values to two decimal places.

Figure 5: Output of converting data values to two decimal places

The data values for columns from Academic to Test_2 after being converted into two decimal
places will be as shown in figure 5 above.



3. Add new columns

Figure 6: Create new column

Select F1 cell and move the cursor to the right corner of the cell until the pointer changes to a
black plus sign +. Then, drag the plus sign to the right to create a new column and rename the
new column G as P1.

Figure 7: Create multiple new columns

To create multiple columns at the same time, repeat the previous step and drag the plus sign + to
column K, and the column name will be automatically updated from P2 to P5 as well.



4. Update values in columns G (P1) to K (P5)

Figure 8: Update values in column G (P1)

To provide a new value for column B (Academic) with the new maximum value of 3.33 for each
column, we use the formula:=([@Academic]/61)*3.33, where 61 is the full marks for Academic.
In order to avoid losing data accidentally, we write this formula into cells underneath column P1
instead of overwriting directly at the cells under Academic column.

Figure 9: Update values in columns H (P2) to K (P5)

For the remaining columns, we repeat the previous step by changing the total marks for each
column referring to the table1 as below:
Column H (P2): =([@Sports]/10)*3.33
Column I (P3): =([@[Co-Curriculum]]/15)*3.33
Column J (P4): =([@[Test_1]]/10)*3.33
Column K (P5): =([@[Test_2]]/10)*3.33

Then, we click enter to autofill the rest of the cells. We can also select the H2 cell and move the
cursor to the right corner of the cell until the pointer changes to a black plus sign +. Double click
the black plus sign + to autofill the column and the new values with two decimal places will be
displayed as shown in figure 9 above.



5. Determine the top three values

Figure 10: Create new columns

Select P5 cell and move the cursor to the right corner of the cell until the pointer changes to a
black plus sign +. Then, drag the plus sign to the right to create a new column and rename the
new column L as B1. Repeat the previous step and drag the plus sign + to column N, and the
column name will be automatically updated from M (B2) to N (B3) as shown in figure 10.

Figure 11: Calculate top 3 values

To calculate the top 3 values in columns G to K, the following formulas is used:
Column L (B1): =LARGE(Dataset1[@[P1]:[P5]],1)
Column M (B2): =LARGE(Dataset1[@[P1]:[P5]],2)
Column N (B3): =LARGE(Dataset1[@[P1]:[P5]],3)



Figure 12: Output of top 3 values

The largest value will be chosen from each row and the first highest value will be filled in
Column L (B1), followed by the second highest value in Column M (B2) and third highest value
in Column N (B3) as shown in figure 12 above.



6. Compute total points

Figure 13: Compute total points

After a new column O (TM) is created, we calculate the total points by using the formula:
=SUM(Dataset1[@[B1]:[B3]]).

Figure 14: Output of total points

Then, click enter to autofill the whole column or select the O2 cell and move the cursor to the
right corner of the cell until the pointer changes to a black plus sign +. Double click the black
plus sign + to autofill the column and the values will be displayed as shown in figure 14 above.



7. Calculate the percentage value

Figure 15: Create new column

Select O1 cell and move the cursor to the right corner of the cell until the pointer changes to a
black plus sign +. Then, drag the plus sign to the right to create a new column and rename the
new column P as Percent.

Figure 16: Compute percentage value

To calculate the percentage value, we use =([@TM]/10)*100, which we make use of the
calculation before in column TM, divide by the total value and multiply by 100.

Figure 17: Output of Percent column

Then, we simply double click the black plus sign, + to autofill the rest cells in the column. The
output should be just like in Figure 17 above.



8. Assign the grade and status

Figure 18: Create two new columns

Create two new columns named “Grade” and “Status” by dragging the black plus sign in the
Percent cell to the next 2 columns on its right side.

Figure 19: Grade and status table

Create a table with marks, grade and status as the columns. Fill the rows with the given details.
This table will be our reference when we look up the grade according to the student’s mark.



Figure 20: Assign a grade

Next, to assign the grade, we implement the vlookup formula where the percentage value from
the Percent column is our lookup value, the reference table with column marks and grade is the
table array. Then, the column index number is assigned to ‘2’ since we would like to retrieve the
value from the Grade column and lastly, true to find the approximate value. Therefore, the
formula will look like this =VLOOKUP(P2,$U$2:$V$14,2,TRUE).

Figure 21: Assign a status

After we are done assigning the grade, we then can assign the status to see whether the student
has passed or failed using the same reference table. The only difference here is instead of ‘2’ as
the column index number, we assign ‘3’. This is because the value that we would like to retrieve
from this time is under the 3rd column which is the Status column. Hence, the formula is
=VLOOKUP(P2,$U$2:$W$14,3,TRUE).



Figure 22: Output for Grade and Status column

After we have clicked for autofills for both Grade and Status columns, we then get the output just
like in Figure 22.



9. Conditional Formatting

Figure 23: The table is set to None design

To avoid confusion, we set the table color to none. This can be done by clicking on the Table
Design tab and choosing ‘None’ in the Table Styles ribbon. Then, we select all the data and click
on the conditional formatting under the Home tab on Styles ribbon. We are going to highlight the
rows with “Pass” status. Click on the ‘New Rule’.

Figure 24: New Rule button is clicked

New Formatting Rule window will be popped out. There, we choose the last rule type in the list.
For the Rule Description, the formula is =$R2 = “Pass” which we give as an example where the
desired cell condition is true. Then, choose the appropriate color by clicking on the Format…
button.



Figure 25: New Formatting Rule window

Click ‘OK’. The sample output is displayed below.

Figure 26: Output of highlighted rows

Next, we would like to highlight the cells under Percent color in green if the Status equals
“Pass”.



Figure 27: Percent column data is selected

Firstly, we need to select the data under the Percent column. This can easily be done by selecting
the first row under the Percent column and pressing Ctrl key + Shift key + Downward arrow key.

Figure 28: New Formatting Rule

Then again, choose to create a New Rule under the Conditional Formatting. Using the same Rule
Type and formula, but with green color, we are able to highlight the cells after we clicked ‘OK’.



Figure 29: Output of highlighted cells

The output is shown above in figure 29 where all the values with status Pass are highlighted with
light red color and percent with status Pass is colored with green.

Figure 30: Change font color

The fonts could also be changed by selecting columns L (B1) to N (B3) and on the Home tab,
choose the color intended in the Font Color button.

Figure 30: Output of colored fonts

The output will be displayed as shown above where the values of columns L (B1) to N (B3) are
in red color.



10. Create a dashboard

Figure 31: Create Dashboard sheet

The dashboard will be created in a new sheet by clicking the new sheet button (plus + icon)
located to the right of the current sheet tabs and then we rename the new sheet to Dashboard.

a. Determine the minimum, maximum and average values

Figure 32: Remove 0 or null values

Filter out the value 0.00 to get a precise calculation and to make sure there are no null values in
the dataset by selecting the column header arrow for the column we want to filter and unselect
the value 0.00 and click OK.



Figure 33: Create pivot table

Highlight the whole dataset and click PivotTable under the Insert tab. Choose the location of the
PivotTable to be placed and click OK.

Figure 34: Pivot Table fields

In the PivotTable fields, drag the Grade to the Rows area field, Percent to both the Columns and
Values area fields. Drag the Percent to the Values area field multiple times and click the
downward arrow at the left of Count of Percent then click Value field settings.. to change the
type of calculation wanted such as Min, Max and Average.



Figure 37: Output of pivot table

Based on the pivot table, we can obtain the result we wanted where the Min of Percent is the
minimum value of percentage and 14.82 is the lowest percentage mark scored among students.
For the maximum value of the Percent column, we can refer to the Max of Percent in the pivot
table where 98.57 is the highest percentage mark scored among students. Lastly, the Average of
Percent shows the average percentage of marks scored by the students.



b. Display grading result

Figure 38: Pivot Table

Next, we would like to analyze how many students for each grade. To display effectively, we
implemented using the Pivot Table. This can be done by selecting the data in column Grade.
Then, insert the Pivot Table. For the fields, drag the Grade into Rows and Values spaces.

Figure 39: Sorted Pivot Table

We rearrange the Row Labels in the Pivot Table as shown in Figure 39.



Figure 40: Insert bar chart

To visualize the data that we have, we inserted a bar graph under the Charts ribbon. Excel will
return a bar graph that looks like in Figure 40. Therefore, we need to adjust manually according
to how we would like it to be.

Figure 41: Format axis

Firstly, we modify the y-axis to display per ten thousand. This can be done by double-clicking
the y-axis value. A pane will be popped up from the right, named ‘Format Axis’ . Choose the



rightmost tab option with the graph icon. Then, expand the Axis Options. Here, we set the
display units as 10000, and major units to 10000.0.

Figure 42: Add axis title

After we are done with the y-axis, it is appropriate to label the Axis Title. Click on the graph,
then click on the green plus sign (+) on the top right corner. A list of chart elements will appear.
To make the Axis Title visible, simply click on the Axis Titles checkbox. Then, rename it as
‘Num. of Students (10k)’. Untick the Chart Title.

Figure 43: Format bar chart colors

To make the bar look more appealing and easy to differentiate between the counts, we can
change the color of the bars. Double click on one of the bars. A Format Data Series pane will



pop out. Under the Bucket icon tab, we can choose to pick color for each bar. However, since we
have quite a number of bars with different values, we can simply tick the ‘Vary colors by point’.
This way, we manage to change the colors faster and easier.

Figure 44: Format bar chart width

Next, in order to make the bars more visible, we can widen the graphs. Under the same pane, we
choose the rightmost tab with the Graph icon. There, we can modify the Gap Width between the
bars. For this case, we set it to 50%.

Figure 45: Output of bar chart

The finalized bar chart will be as shown above in Figure 45.



c. Determine the total records, pass and fail values

Then, we would like to highlight the grand total value in thousand where ‘K’ is displayed after
the last value.

Figure 46: Format cell number

This can be done by copy and paste the grand total value to another cell. Then, we change the
format by clicking the More Number Formats… in the dropdown under the Numbers ribbon.
After the Format Cells window popped out, choose the Custom category. In the Type
placeholder, type in 0, K. Click ‘OK’.

Figure 47: Output of formatted cell number

The output will be displayed as shown in figure above. Then, to round off the number into the
nearest 10,000 by using the formula: =MROUND(GETPIVOTDATA("Grade",$U$20),10000)
where $U$20 is the location of the value in the worksheet.



Figure 48: Create status pivot table

Next, we want to count the number of students for each Status. We did this by highlighting the
column R (Status) and inserting the Pivot Table. Then, we drag the Status into Rows and Values
space. Automatically, the Pivot Table will display “Fail” and “Pass” with their count values.

Figure 49: Change value field

Since we want to determine the percentage of both fail and pass, we first copy the original value
of Count of status and paste it to other cells. Then, we can right click on the Count of status and



select the Value Field Settings. Once the dialog box is displayed, click on the Show Values As
tab and click on the drop down list to select the % of Grand Total option to get the percentage of
Fail and Pass.

Figure 50: Output of grand total in percentage

The output should look like in figure above after changing the value field and the decimal places
are decreased to 2 decimal places.

d. Illustrate pie chart

Figure 51: Create pie chart

To visualize the percentage, it is appropriate to use the pie chart or the doughnut chart. In this
case, we use the doughnut chart which can be found in the Insert tab under the Charts ribbon.



Figure 52: Format pie chart

We then untick the Chart Title in Chart Elements. To modify the color of the slices, double click
the specific slices. The Format Data Point pane will pop out. Choose the desired color under the
Bucket icon tab, after expanding the Fill section.

Figure 53: Output of pie chart

The finalized pie chart will be as shown above in Figure 53.



e. Creating dashboard layout

Figure 54: Add dashboard background

We remove the gridlines by untick the view box under sheet options in the Page Layout tab.
Then, we can add a background by clicking on the Background to add an image into the sheet.

Figure 55: Add dashboard layout

After adding the background, we then insert shapes in the Insert tab and select Illustration to
create the layout of the dashboard. The size and design of the shapes for the layout can be
formatted in the Shape Format tab.



Figure 56: Output of background and layout

The base design of the dashboard will be as shown above after adding the shapes.

Figure 57: Insert text

To insert text, go to the Insert tab and select the text box to insert the text box and we can edit the
text as usual.

Figure 58: Output of dashboard layout

After adding the texts, the design of the dashboard is as in Figure 58.



Figure 59: Add values into dashboard

To add values into the each box, we first insert the text box and copy from the previous working
and Paste Special > Formula or write the following formula:
Min: =Dataset1!$AB$15
Max: =Dataset1!$AC$15
Average: =Dataset1!$AD$15
Total Record: =Dataset1!$X$34
Pass: =Dataset1!$V$38 (percentage) =Dataset1!$Y$38 (records)
Fail: =Dataset1!$V$37 (percentage) =Dataset1!$Y$37 (records)

Figure 60: Output after adding values

All values will be linked from the dataset1 worksheet and be displayed in the dashboard
worksheet as shown in Figure 60.



Figure 61: Add table into dashboard

From the pivot table of Grade we created previously, we copy the data of the table and paste it in
the dashboard via paste link so we would not need to type it individually as this function inserts
the table references to the copied cell range.

Figure 62: Edit grade table

Add the table header Grade and Data for the table. Then, add All Borders, fill the table color
with white and bold the table header and total in the Home tab.

Figure 63: Output of grade table

The output of the grade table will be as shown above.



Figure 64: Add bar chart and pie chart

To add the bar chart and pie chart into the dashboard, we copy the graphs and paste it in the
layout prepared in the dashboard. Then, we resize the graphs to make it fit to the shape of the
layout.

Figure 65: Output of dashboard

The finalized dashboard is as shown in Figure 65.


